您的位置:首页 > 产品设计 > UI/UE

HDU 2734 Quicksum【水 字符串】

2016-01-14 21:11 609 查看

Quicksum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3121 Accepted Submission(s): 2300

[align=left]Problem Description[/align]
A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating
document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

[align=left]Input[/align]
The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

[align=left]Output[/align]
For each packet, output its Quicksum on a separate line in the output.

[align=left]Sample Input[/align]

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

[align=left]Sample Output[/align]

46
650
4690
49
75
14
15

简单的字符串处理........

#include<stdio.h>
int main()
{
char s[1005];
while(gets(s),s[0]!='#')
{
long long sum=0;
for(int i=0;s[i];++i)
{
if(s[i]!=' ')
{
sum+=(s[i]-'A'+1)*(i+1);
}
}
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: