您的位置:首页 > 其它

HDU 1020 Encoding

2016-01-14 16:21 351 查看

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 36115    Accepted Submission(s): 16002


[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

 

[align=left]Output[/align]
For each test case, output the encoded string in a line.

 

[align=left]Sample Input[/align]

2
ABC
ABBCCC

 

[align=left]Sample Output[/align]

ABC
A2B3C
水题,直接上代码

#include <stdio.h>
#include <string.h>
int main()
{
int T,len,sum,i;
char str[10005];
scanf("%d",&T);
getchar();
while(T--)
{
char temp;
sum=1;
gets(str);
len=strlen(str);
temp=str[0];
for(i=1;i<=len;i++)
{
if(str[i]==str[i-1])
sum++;
else
{
if(sum!=1)
printf("%d",sum);
printf("%c",temp);
temp=str[i];
sum=1;
}
}
putchar('\n');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: