您的位置:首页 > 其它

Poj 2676 Sudoku

2016-01-14 15:35 417 查看
Sudoku

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 16554Accepted: 8075Special Judge
Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with
decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.



Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty
it is represented by 0.
Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
Sample Input
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

Source
Southeastern Europe 2005

思路:纯暴力的dfs搜索,对0,也就是还没有数字的格子进行判断,可以就继续下一个格子,不行就换数字,再不行就回溯,不过
这里要注意,如果遍历整个图的话,会超时,所以只需要记录下空格的就行了。
AC代码如下:
#include <iostream>
#include <cstring>
using namespace std;

const int maxn=15;
int mp[maxn][maxn];
bool ok=false;
struct Node{
    int x,y;
}q[maxn*maxn];
int cnt=0;

bool safe(int i,int cn){

   // if(mp[x][y]) return false;
    int x=q[cn].x,y=q[cn].y;
    for(int j=0;j<9;j++)
        if(mp[x][j]==i) return false;
    for(int j=0;j<9;j++)
        if(mp[j][y]==i) return false;
    int tx=x/3;
    int ty=y/3;
    for(int j=(tx)*3;j<(tx)*3+3;j++){
        for(int k=(ty)*3;k<(ty)*3+3;k++)
            if(mp[j][k]==i) return false;
    }
    return true;
}
void show(){
      for(int i=0;i<9;i++){
            for(int j=0;j<9;j++)
            cout<<mp[i][j];
        cout<<endl;
    }
}
void dfs(int cn){
    if(ok) return ;
    if(cn<0){
        ok=true;
        show();
        return ;
    }
    int x=q[cn].x,y=q[cn].y;
    for(int i=1;i<=9;i++){
        if(safe(i,cn)){
            mp[x][y]=i;
            if(ok) return ;
            dfs(cn-1);

        }
    }
    if(ok) return ;
    mp[x][y]=0;return ;
}

int main(){

    int t;
    cin>>t;
    while(t--){
        ok=false;
        cnt=0;
        memset(mp,0,sizeof(mp));

        for(int i=0;i<9;i++){
            for(int j=0;j<9;j++){
                char xx;
                cin>>xx;
                mp[i][j]=xx-'0';
                if(mp[i][j]==0){
                        Node tmp;
                        tmp.x=i,tmp.y=j;
                    q[cnt++]=tmp;
                }
            }
        }
            dfs(cnt-1);
        }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: