您的位置:首页 > 其它

hdoj5475An easy problem【线段树】

2016-01-13 21:22 316 查看


An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1149    Accepted Submission(s): 563


Problem Description

One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.

1. multiply X with a number.

2. divide X with a number which was multiplied before.

After each operation, please output the number X modulo M.

 

Input

The first line is an integer T(1≤T≤10),
indicating the number of test cases.

For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤109)

The next Q lines, each line starts with an integer x indicating the type of operation.

if x is 1, an integer y is given, indicating the number to multiply. (0<y≤109)

if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.

 

Output

For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.

Then Q lines follow, each line please output an answer showed by the calculator.

 

Sample Input

1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7

 

Sample Output

Case #1:
2
1
2
20
10
1
6
42
504
84

 

Source

2015 ACM/ICPC Asia Regional Shanghai Online

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int maxn=100010;

int MOD;
long long sum[maxn<<2];
void pushup(int rt){
sum[rt]=(sum[rt<<1]*sum[rt<<1|1])%MOD;
}
void build(int l,int r,int rt){
if(l==r){
sum[rt]=1;
return ;
}
int mid=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void update(int pos,long long k,int l,int r,int rt){
if(l==r){
sum[rt]=k;
return ;
}
int mid=(l+r)>>1;
if(pos<=mid)update(pos,k,lson);
else update(pos,k,rson);
pushup(rt);
}
long long query(int left,int right,int l,int r,int rt){
if(l>right||r<left)return 1;
if(left<=l&&r<=right){
return sum[rt];
}
int mid=(l+r)>>1;
return (query(left,right,lson)*query(left,right,rson))%MOD;
}
int main()
{
int t,i,j,k=1,n;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&MOD);
long long a,b;
build(1,n,1);
printf("Case #%d:\n",k++);
for(i=1;i<=n;++i){
scanf("%lld%lld",&a,&b);
if(a==1){
update(i,b,1,n,1);
printf("%lld\n",query(1,i,1,n,1));
}
else {
update(b,1,1,n,1);
printf("%lld\n",query(1,i,1,n,1));
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj5475An easy prob