您的位置:首页 > 其它

POJ 1703 Find them, Catch them(并查集)

2016-01-13 18:01 190 查看
[align=center]Find them, Catch them[/align]

Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 38474
Accepted: 11839
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify
which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 

where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed
by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs."
and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


题意:城市里有两个帮派,给出n个人, D a b表示a和b不是一个帮派的,A a b 表示询问a和b的关系(1. 不清楚,2.不是一个帮派的,3.是一个帮派的)

题解:和POJ  1182  食物链很像,可以把每个人看成两个生命体,即x,x+n;出现D a b时合并a和b+n, b和a+n即可。

代码如下:

#include<cstdio>
#include<cstring>
int tree[200100];

int find(int x)
{
if(tree[x]==x)
return x;
else
return tree[x]=find(tree[x]);
}

void merge(int a,int b)
{
int fa=find(a);
int fb=find(b);
if(fa!=fb)
tree[fa]=fb;
}

int main()
{
int t,i,n,m,x,y;
char s[2];
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(i=1;i<=2*n;++i)
tree[i]=i;
while(m--)
{
scanf("%s%d%d",&s,&x,&y);
if(s[0]=='D')
{
merge(x,y+n);
merge(x+n,y);
}
else
{
if(find(x)==find(y))
printf("In the same gang.\n");
else if(find(x)==find(y+n)||find(x+n)==find(y))
printf("In different gangs.\n");
else
printf("Not sure yet.\n");
}
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: