您的位置:首页 > 其它

Poj 2386 Lake Counting

2016-01-13 17:57 316 查看
Lake Counting

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 25835Accepted: 12979
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.
Source

USACO 2004 November

思路:简单的搜索,每次找到一个W就从这个W开始,遍历所有相邻的W

AC代码如下

#include <iostream>
using namespace std;
const int maxn=100+5;
int vis[maxn][maxn];
char mp[maxn][maxn];
int xx[]={1,1,1,-1,-1,-1,0,0};
int yy[]={1,-1,0,1,-1,0,1,-1};

int n,m;

void dfs(int x,int y){

    vis[x][y]=1;
    mp[x][y]='.';

    for(int i=0;i<8;i++){
        int tx=xx[i]+x;
        int ty=yy[i]+y;
        if(tx>=0 && tx<n && ty>=0 && ty<m && !vis[tx][ty] && mp[tx][ty]=='W')
            dfs(tx,ty);
    }

}

int main(){

    cin>>n>>m;
    for(int i=0;i<n;i++) cin>>mp[i];
    int cnt=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        if(!vis[i][j] && mp[i][j]=='W'){
            cnt++;
            dfs(i,j);
        }
    cout<<cnt<<endl;

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: