您的位置:首页 > 其它

poj--1383--Labyrinth(树的直径)

2016-01-13 17:51 387 查看
Labyrinth

Time Limit: 2000MSMemory Limit: 32768K
Total Submissions: 4062Accepted: 1529
Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have
found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means
also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow,
each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks
are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth.

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input

2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output

Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended.

If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc
Source

Central Europe 1999

寻找两个相差最远的‘.’,树的直径两次bfs,先找一个最长路,然后从端点开始继续搜

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
struct node
{
int x,y,step;
}temp,p;
int vis[1010][1010],sx,sy,ans,m,n;
char map[1010][1010];
void init()
{
memset(map,'\0',sizeof(map));
memset(vis,0,sizeof(vis));
ans=0;
sx=sy=0;
}
void getmap()
{
int flag=0;
for(int i=0;i<m;i++)
{
scanf("%s",map[i]);
for(int j=0;j<n&&!flag;j++)
{
if(map[i][j]=='.')
{
sx=i;
sy=j;
flag=1;
}
}
}
}
int judge(node s1)
{
if(s1.x<0||s1.x>=m||s1.y<0||s1.y>=n)
return 1;
if(map[s1.x][s1.y]=='#'||vis[s1.x][s1.y])
return 1;
return 0;
}
void bfs(int x,int y)
{
memset(vis,0,sizeof(vis));
queue<node>q;
p.x=sx;
p.y=sy;
p.step=0;
q.push(p);
vis[sx][sy]=1;
while(!q.empty())
{
p=q.front();
q.pop();
for(int i=0;i<4;i++)
{
temp.x=p.x+dx[i];
temp.y=p.y+dy[i];
if(judge(temp)) continue;
temp.step=p.step+1;
if(temp.step>ans)
{
ans=temp.step;
sx=temp.x;
sy=temp.y;
}
vis[temp.x][temp.y]=1;
q.push(temp);
}
}
}
void solve()
{
bfs(sx,sy);
bfs(sx,sy);
printf("Maximum rope length is %d.\n",ans);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
getmap();
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: