您的位置:首页 > 其它

【POJ】1287 - Networking(最小生成树(克鲁斯塔尔),水)

2016-01-13 12:29 405 查看
Networking

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 7698Accepted: 4216
Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are
given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the
area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.
Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points.
The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only
one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j
i.

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.
Sample Input
1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output
0
17
16
26

Source

Southeastern Europe 2002

用克鲁斯塔尔算,不难的最小生成树的题。

代码如下:

#include <stdio.h>
#include <algorithm>
using namespace std;

struct node
{
	int st,end,cost;
}a[2500];		//记录每一条路 

int pp[55];

bool cmp(node a,node b)		//按花销从小到大排序 
{
	return a.cost<b.cost;
}

int find(int x)
{
	int r=x;
	while (r!=pp[r])
		r=pp[r];
	int j=x;
	int t;
	while (pp[j]!=r)
	{
		t=pp[j];
		pp[j]=r;
		j=t;
	}
	return r;
}
int join(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if (fx!=fy)
	{
		pp[fx]=fy;
		return 1;		//不一棵树返回1 
	}
	return 0;
}

int main()
{
	int p,r;		//点,路线数
	int ans;
	int num;		//完成连接的数量,等于p-1时终止 
	while (~scanf ("%d",&p) && p)
	{
		scanf ("%d",&r);
		//首先初始化
		for (int i=1;i<=p;i++)
		{
			pp[i]=i;
		}
		ans=0;
		num=0;
		//输入
		for (int i=0;i<r;i++)
		{
			scanf ("%d %d %d",&a[i].st,&a[i].end,&a[i].cost);
		}
		if (p==1)
		{
			printf ("0\n");
			continue;
		}
		sort (a,a+r,cmp);		//花费从小到大排序
		for (int i=0;i<r;i++)
		{
			if (join(a[i].st,a[i].end))
			{
				ans+=a[i].cost;
				num++;
			}
			if (num==p-1)
				break;
		}
		printf ("%d\n",ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: