您的位置:首页 > 大数据 > 人工智能

hdu1021——Fibonacci Again

2016-01-13 11:14 609 查看

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 47893 Accepted Submission(s): 22743



[align=left]Problem Description[/align]
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

[align=left]Input[/align]
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

[align=left]Output[/align]
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

[align=left]Sample Input[/align]

0
1
2
3
4
5


[align=left]Sample Output[/align]

no
no
yes
no
no
no


感觉自己学聪明了,第一眼看到这题后想到的不是暴力算,而是找规律。

判断能不能被3整除,那么整个斐波那契数列只需要保留0,1,2,这三个数就行了。只有三个数,那么很有可能在某处存在一个周期。结果推出了前10个,分别是1,2,0,2,2,1,0,1,1,2。这是周期已经出现了,为8。

代码实现如下:

#include<iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n%8==2||n%8==6) cout<<"yes"<<endl;
else cout<<"no"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: