您的位置:首页 > 其它

hdoj Free DIY Tour 1224 (树形DP记录路径)

2016-01-13 10:16 288 查看

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5387    Accepted Submission(s): 1730


[align=left]Problem Description[/align]
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's
a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its
interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In
order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both
1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

[align=left]Input[/align]
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.

Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.

Then N integers follows, representing the interesting point list of the cities.

And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

[align=left]Output[/align]
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only
one optimal circuit.

Output a blank line between two cases.

[align=left]Sample Input[/align]

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

[align=left]Sample Output[/align]

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1//题意:在n+1座城市编号为(1---n+1)中有m条路,并且每座城市有一个宝藏,问怎样走你可以获得最大宝藏。HAIT:只能从编号小的走到编号大的。输入:先输入一个n表城市的个数,接下来是n个数表每个城市的宝藏,然后输入一个m,表示有m条路,接着是m条路。输出:样例数; 最大宝藏; 路径;
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[110];
int v[110];
int dp[110];
int map[110][110];
void print(int n)
{
if(n==a
)
{
printf("%d",n);
return ;
}
print(a
);
printf("->%d",n);
}
int main()
{
int t,T=1,n,m,i,j,k;
int x,y;
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
memset(map,0,sizeof(map));
scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&v[i]);
a[i]=1;
}
scanf("%d",&m);
for(i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
map[x][y]=1;
}
v[n+1]=0;
for(i=1;i<=n+1;i++)
{
for(j=1;j<i;j++)
{
if(map[j][i]&&dp[j]+v[i]>dp[i])
{
dp[i]=dp[j]+v[i];
a[i]=j;
}
}
}
printf("CASE %d#\n",T++);
printf("points : %d\n",dp[n+1]);
printf("circuit : ");
print(a[n+1]);
printf("->%d\n",1);
if(t)
printf("\n");
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: