您的位置:首页 > 其它

POJ2653(Pick-up sticks)(线段相交问题)

2016-01-12 14:32 501 查看
Pick-up sticks

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11507 Accepted: 4322
Description

Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown
stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
Input

Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks
are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output

For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown. 

The picture to the right below illustrates the first case from input.


Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint

Huge input,scanf is recommended.

题意:给你一些线段,将那些未被压到的线段输出~

其实还是判断线段是否相交的问题。

#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
double x,y;
};
struct st
{
node a,b;
}data[100010];
int judge(int i,int j)
{
if(min(data[i].a.x,data[i].b.x)>max(data[j].a.x,data[j].b.x))
return 0;
if(min(data[i].a.y,data[i].b.y)>max(data[j].a.y,data[j].b.y))
return 0;
if(min(data[j].a.x,data[j].b.x)>max(data[i].a.x,data[i].b.x))
return 0;
if(min(data[j].a.y,data[j].b.y)>max(data[i].a.y,data[i].b.y))
return 0;
double h=(data[i].a.x-data[j].a.x)*(data[j].b.y-data[j].a.y)-(data[i].a.y-data[j].a.y)*(data[j].b.x-data[j].a.x);
double k=(data[i].b.x-data[j].a.x)*(data[j].b.y-data[j].a.y)-(data[i].b.y-data[j].a.y)*(data[j].b.x-data[j].a.x);
double m=(data[j].a.x-data[i].a.x)*(data[i].b.y-data[i].a.y)-(data[j].a.y-data[i].a.y)*(data[i].b.x-data[i].a.x);
double n=(data[j].b.x-data[i].a.x)*(data[i].b.y-data[i].a.y)-(data[j].b.y-data[i].a.y)*(data[i].b.x-data[i].a.x);
return h*k<=0&&m*n<=0;
}
int main()
{
int n,j;
while(scanf("%d",&n),n)
{
for(int i=1;i<=n;i++)
scanf("%lf%lf%lf%lf",&data[i].a.x,&data[i].a.y,&data[i].b.x,&data[i].b.y);
printf("Top sticks: ");
for(int i=1;i<n;i++)
{
for(j=i+1;j<=n;j++)
{
if(judge(i,j))
break;
}
if(j==n+1)
printf("%d, ",i);
}
printf("%d.\n",n);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: