您的位置:首页 > 其它

HDU 3555 Bomb(数位DP)

2016-01-11 18:32 441 查看

                

                Bomb

                      Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
                            Total Submission(s): 11804 Accepted Submission(s): 4212


[align=left]Problem Description[/align]
The
counter-terrorists found a time bomb in the dust. But this time the
terrorists improve on the time bomb. The number sequence of the time
bomb counts from 1 to N. If the current number sequence includes the
sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

[align=left]Input[/align]
The
first line of input consists of an integer T (1 <= T <= 10000),
indicating the number of test cases. For each test case, there will be
an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.

[align=left]Sample Input[/align]

3
1
50
500

[align=left]Sample Output[/align]

0
1
15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

[align=left]Author[/align]
fatboy_cw@WHU

[align=left]Source[/align]
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

【思路】

数位DP。

   预处理:

f[i][0] 表示i位数中不含49的数的数目

f[i][1] 表示i位数中不含49且最高位为9的数的数目

f[i][1] 表示i位数中含49的数的数目

根据n的每一位统计ans,具体见代码。

【代码】

#include<cstdio>
using namespace std;

typedef long long LL;
LL f[25][3];
/*
f[i][0] i位数 无49存在
f[i][1] i位数 无49存在且末尾为9
f[i][2] i位数 有49
*/
int b[25];

void init() {
f[0][0]=1; f[0][1]=f[0][2]=0;
for(int i=1;i<25;i++) {
f[i][0]=10*f[i-1][0]-f[i-1][1];
f[i][1]=f[i-1][0];
f[i][2]=10*f[i-1][2]+f[i-1][1];
}
}

int main() {
int T; LL n;
scanf("%d",&T);
init();
while(T--) {
scanf("%I64d",&n);
int len=0;
while(n)
b[++len]=n%10 , n/=10;
b[len+1]=0;
LL ans=0; bool flag=0;
for(int i=len;i;i--) {
ans += b[i]*f[i-1][2];                    // + ...49...
if(flag) ans += f[i-1][0]*b[i];            // + 49...(无49...)
else if(b[i]>4) ans += f[i-1][1];        // + 4(9 无49)
if(b[i+1]==4 && b[i]==9) flag=1;
}
if(flag) ans++;                                //算上自身
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: