您的位置:首页 > 其它

poj--3169--Layout(简单差分约束)

2016-01-11 18:11 381 查看
Layout

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9098 Accepted: 4347
Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they
can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other
and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3

Sample Output
27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source

USACO 2005 December Gold
[Submit]   [Go Back]   [Status]  
[Discuss]


Home Page   

Go
Back  

To top

注意点:

1. 如果要求最大值想办法把每个不等式变为标准x-y<=k的形式,然后建立一条从y到x权值为k的边,变得时候注意x-y<k =>x-y<=k-1

   如果要求最小值的话,变为x-y>=k的标准形式,然后建立一条从y到x的k边,求出最长路径即可

2.如果权值为正,用dj,spfa,bellman都可以,如果为负不能用dj,并且需要判断是否有负环,有的话就不存在

#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define MAXN 1010
#define MAXM 1000000+10
#define INF 10000000+10
int head[MAXN],dist[MAXN],used[MAXN],vis[MAXN];
int n,x,y,cnt;
struct node
{
int u,v,val;
int next;
}edge[MAXM];
void init()
{
memset(head,-1,sizeof(head));
cnt=0;
}
void add(int u,int v,int val)
{
node E={u,v,val,head[u]};
edge[cnt]=E;
head[u]=cnt++;
}
void getmap()
{
for(int i=1;i<n;i++)
add(i+1,i,0);
int a,b,c;
while(x--)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
}
while(y--)
{
scanf("%d%d%d",&a,&b,&c);
add(b,a,-c);
}
}
void SPFA()
{
queue<int> Q;
for(int i = 1; i <= n; i++)
{
dist[i] = i==1 ? 0 : INF;
vis[i] = false;
used[i] = 0;
}
//	memset(vis,0,sizeof(vis));
//	memset(dist,INF,sizeof(dist));
//	memset(used,0,sizeof(used));
//	dist[1]=0;
used[1] = 1;
vis[1] = 1;
Q.push(1);
while(!Q.empty())
{
int u = Q.front();
Q.pop();
vis[u] = 0;
for(int i = head[u]; i != -1; i = edge[i].next)
{
node E = edge[i];
if(dist[E.v] > dist[u] + E.val)
{
dist[E.v] = dist[u] + E.val;
if(!vis[E.v])
{
vis[E.v] = 1;
used[E.v]++;
if(used[E.v] > n)
{
printf("-1\n");
return ;
}
Q.push(E.v);
}
}
}
}
if(dist
== INF)
printf("-2\n");
else
printf("%d\n", dist
);
}
int main()
{
while(scanf("%d%d%d",&n,&x,&y)!=EOF)
{
init();
getmap();
SPFA();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: