您的位置:首页 > 其它

POJ 题目2992 Divisors(组合数因子个数)

2016-01-06 20:13 459 查看
Divisors

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11001Accepted: 3259
Description

Your task in this problem is to determine the number of divisors of Cnk. Just for fun -- or do you need any special reason for such a useful computation?
Input

The input consists of several instances. Each instance consists of a single line containing two integers n and k (0 ≤ k ≤ n ≤ 431), separated by a single space.
Output

For each instance, output a line containing exactly one integer -- the number of distinct divisors of Cnk. For the input instances, this number does not exceed 263 - 1.
Sample Input
5 1
6 3
10 4

Sample Output
2
6
16

Source
CTU Open 2005
求c(n,m)的因子个数
判断N!中有几个质因子:P(N!)=N/i+N/i^2+N/i^3+.....N/i^m(i为一个质因子,m是使N/i^m=0的最小值)

ac代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#define LL long long
using namespace std;
LL pri[83]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53,59,61,67,71,73,79,83,89,97,101,103,107,109,113,127,131,137,139,149,151,157,163,167,173,179,181,191,193,197,199,211,223,227,229,233,239,241,251,257,263,269,271,277,281,283,293,307,311,313,317,331,337,347,349,353,359,367,373,379,383,389,397,401,409,419,421,431};
LL c[432][432];
LL slo(LL n,LL x)
{
LL ans=0;
LL sum=x;
while(n>=sum)
{
ans+=n/sum;
sum*=x;
}
return ans;
}
void fun()
{
LL i,j;
for(i=1;i<=431;i++)
for(j=0;j<83;j++)
c[i][j]=slo(i,pri[j]);
}
int main()
{
LL n,m;
fun();
while(scanf("%lld%lld",&n,&m)!=EOF)
{
//        LL ans=c
[m];
LL ans=1;
int i;
for(i=0;i<83&&pri[i]<=n;i++)
{
ans*=(c
[i]-c[n-m][i]-c[m][i]+1);
}
printf("%lld\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: