您的位置:首页 > 其它

华为oj:输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数

2016-01-05 20:03 363 查看
/*输入

输入一行字符串,可以有空格

输出

统计其中英文字符,空格字符,数字字符,其他字符的个数

样例输入 1qazxsw23 edcvfr45tgbn hy67uj m,ki89ol.\/;p0-=\][

样例输出 26 3 10 12*/

华为oj测试的时候,一般输出都会采用换行格式,不然编译说格式错误,请大家注意

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<cctype>
using namespace std;

int main(){
string str;
getline(cin, str);
int letter_num = 0, space_num = 0, digit_num = 0, oher_num = 0;
for (int i = 0; i != str.size(); i++){
if (isalpha(str[i])) letter_num++;
else if (isspace(str[i])) space_num++;
else if (isdigit(str[i])) digit_num++;
else oher_num++;
}
cout << letter_num << endl << space_num << endl << digit_num << endl << oher_num << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: