您的位置:首页 > 其它

1029

2016-01-05 18:47 369 查看


Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)

Total Submission(s): 23290    Accepted Submission(s): 9753


Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is
terminated by the end of file.

 

Output

For each test case, you have to output only one line which contains the special number you have found.

 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

 

Sample Output

3
5
1

    寻找多数问题,这里由于n是奇数,答案也保证存在,所以可以省去检验,于是省掉了一个数组。

    观察结果可以得出结论,如果在数组中删除任意两个不同的数,得到的新数组的答案与原数组相同。

    于是就从头开始,用变量b记录现在最多的数,cnt表示其存在个数,每次扫到一个数a

    如果cnt==0,则b=a;否则

        if(a==b)cnt++;

        else cnt--;

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

int n;

int main()
{
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
while(scanf("%d",&n)==1)
{
int a,b,cnt=0;
while(n--)
{
scanf("%d",&a);
if(cnt)
{
if(a==b)cnt++;
else cnt--;
}
else
{
b=a;
cnt=1;
}
}
printf("%d\n",b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: