您的位置:首页 > 其它

hdoj1597find the nth digit

2016-01-04 08:55 197 查看


find the nth digit

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 10159 Accepted Submission(s): 2989



Problem Description

假设:

S1 = 1

S2 = 12

S3 = 123

S4 = 1234

.........

S9 = 123456789

S10 = 1234567891

S11 = 12345678912

............

S18 = 123456789123456789

..................

现在我们把所有的串连接起来

S = 1121231234.......123456789123456789112345678912.........

那么你能告诉我在S串中的第N个数字是多少吗?

Input

输入首先是一个数字K,代表有K次询问。

接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output

对于每个N,输出S中第N个对应的数字.

Sample Input

6
1
2
3
4
5
10


Sample Output

1
1
2
1
2
4


代码:

#include<cstdio>
int main()
{
int n;
scanf("%d",&n);
while (n--)
{
int x,i;
scanf("%d",&x);
if(x==1)
{
printf("1\n");
continue;
}
for (i=1;x>i;i++)
x-=i;
if (x%9==0)
x=9;
else if (x>9)
x%=9;
printf("%d\n",x);
}
return 0;
}

为什么下面这个就超时呢,,知道的麻烦给我说下
#include<cstdio>
int main()
{
int n;
scanf("%d",&n);
while (n--)
{
int x,i;
scanf("%d",&x);
if(x==1)
{
printf("1\n");
continue;
}
for (i=1;i*(i+1)/2<x;i++);
int s=x-i*(i-1)/2;
if (s%9==0)
s=9;
else if (s>9)
s%=9;
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: