您的位置:首页 > 其它

POJ 1979-Red and Black【基础DFS】

2016-01-03 16:15 381 查看
Red and Black

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 27684Accepted: 15033
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

Source

Japan 2004 Domestic

解题思路

找到@可以行动的区域,看清楚N和M谁代表行谁代表列。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
#define M 300
using namespace std;
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
int n,m,x,y;
bool vis[M][M];
char map[M][M];
int ans;
void F(int xx,int yy)
{
int i,j;
for(i=0;i<4;i++)
{
if(map[xx+dx[i]][yy+dy[i]]=='.'&&vis[xx+dx[i]][yy+dy[i]]==false&&xx+dx[i]>=0&&yy+dy[i]>=0&&xx+dx[i]<m&&yy+dy[i]<n)
{
vis[xx+dx[i]][yy+dy[i]]=true;
ans++;
//printf("%d %d\n",xx+dx[i],yy+dy[i]);
F(xx+dx[i],yy+dy[i]);
}
}
}
int main()
{
while(scanf("%d%d",&n,&m)&&(n||m))
{
memset(vis,false,sizeof(vis));
for(int i=0;i<m;i++)
{
getchar();
for(int j=0;j<n;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@')
{
x=i,y=j;
vis[i][j]=true;
}
}
}
ans=0;
F(x,y);
printf("%d\n",ans+1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: