您的位置:首页 > 其它

进阶训练一.水题

2016-01-03 11:08 295 查看

Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input聽

1 1 3
1 2 10
0 0 0

Sample Output

2
5

分析:水题一枚。这题的特点在于如果要自己找规律的话非常难找,因为f(n-1)有可能是0-6,f(n-2)也是,共49种可能,所以最好的方法是设计程序让程序找规律

代码:

#include<stdio.h>
int main()
{
int i, j, n,a,b,begin,end,flag,str[60];
while (1)
{
scanf("%d%d%d", &a, &b, &n);
if (a == 0 && b == 0 && n == 0)
break;
str[1] = str[2] = 1;
flag = 0;
for (i = 3;i <= n&&!flag;i++)
{
str[i] = (a*str[i - 1] + b*str[i - 2]) % 7;
for (j = 2;j < i;j++)
{
if (str[i - 1] == str[j - 1] && str[i - 2] == str[j - 2])
{
flag = 1;
begin = j;
end = i;
break;
}
}
}
if (flag)
printf("%d\n", str[begin + (n - end) % (end - begin)]);
else
printf("%d\n", str
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: