您的位置:首页 > 其它

poj3620Avoid The Lakes【dfs】

2016-01-02 21:01 253 查看
Language:
Default

Avoid The Lakes

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7223 Accepted: 3829
Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his
farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the
cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected
cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K

* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input
3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output
4

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=110;
int n,m,ans,temp;
bool map[maxn][maxn];
bool vis[maxn][maxn];
bool judge(int x,int y){
return x>=1&&x<=n&&y>=1&&y<=m&&!vis[x][y]&&map[x][y];
}
void dfs(int x,int y){
if(!judge(x,y))return ;
vis[x][y]=true;
temp++;
dfs(x,y-1);dfs(x,y+1);
dfs(x-1,y);dfs(x+1,y);
}
int main()
{
int i,j,k,x,y;
while(scanf("%d%d%d",&n,&m,&k)!=EOF){
memset(vis,false,sizeof(vis));
memset(map,false,sizeof(map));
for(i=0;i<k;++i){
scanf("%d%d",&x,&y);
map[x][y]=true;
}
ans=0;
for(i=1;i<=n;++i){
for(j=1;j<=m;++j){
if(map[i][j]&&!vis[i][j]){
temp=0;dfs(i,j);
ans=max(ans,temp);
}
}
}
printf("%d\n",ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj3620Avoid The Lak