您的位置:首页 > 其它

HDU 1089.Ignatius's puzzle【数学题】【2016年1月2】

2016-01-02 00:15 323 查看
Ignatius's puzzle

[align=left]Problem Description[/align]
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer
a,make the arbitrary integer x ,65|f(x)if

no exists that a,then print "no".

[align=left]Input[/align]
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

[align=left]Output[/align]
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

[align=left]Sample Input[/align]

11
100
9999


[align=left]Sample Output[/align]

22
no
43


题意很明确,只要符合题意的x存在就行,不妨令x=1,然后直接计算。代码如下:

#include<iostream>
using namespace std;
int main()
{
int k;
while(cin >> k)
{
int f[70] = {0};
bool flag = false;
for(int i = 1;; ++i)
{
if((i*k+18) % 65 == 0)
{
cout << i << endl;
flag = true;
break;
}
if(f[(i*k+18)%65]) break;//产生循环
f[(i*k+18)%65] = 1;//标记
}
if(!flag) cout <<"no"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: