您的位置:首页 > 其它

搜索入门-----POJ3620

2015-12-29 14:33 274 查看
Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his
farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and
M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly
K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares
a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K

* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column:
R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input
3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output
4

题意就是一个矩形田地被水淹了,有的小方块湿的,有的干的,求湿方块最多相连几个
输入三个数,代表矩形的行(N)和列(M),以及湿方块的个数(K),接下来K行代表湿方块坐标
输出湿方块相连的最大值

#include<cstdio>
int s[102][102], cou;
int sea(int m, int n){
if(s[m]
){//  如果是湿方块,开始计数
cou++;
s[m]
= 0;//  计数过不能再用
sea(m + 1, n);
sea(m, n + 1);
sea(m - 1, n);
sea(m, n - 1);
}
return cou;
}
int main(){
int a, b, c, x, y;
while(~scanf("%d%d%d", &a, &b, &c)){
for(int i = 0; i < a; i++){
for(int j = 0; j < b; j++){
s[i][j] = 0;//   干方块为 0
}
}
for(int i = 1; i <= c; i++){
scanf("%d%d", &x, &y);
s[x][y] = 1;//  湿方块为 1
}
int max = 1;
for(int m = 1; m <= a; m++){
for(int n = 1; n <= b; n++){
cou = 0;
max = sea(m, n) > max ? sea(m, n) : max;//   比较每次查找的相连的湿方块与之前查找的最大的谁更大
}
}
printf("%d\n", max);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: