您的位置:首页 > 其它

第六届福建省大学生程序设计竞赛-重现赛,Problem B Common Tangents【数学几何】

2015-12-28 15:58 656 查看
Problem B Common Tangents

Accept: 191 Submit: 608

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.



Now given the center and radius of two circles, your job is to find how many common tangents between them.



Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the
first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.



Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.



Sample Input

3

10 10 5 20 20 5

10 10 10 20 20 10

10 10 5 20 10 5



Sample Output

4

2

3
题意:求两个圆的切线有几条;
思路,求出两个圆心之间的距离,比较5种情况:重合输出-1 无数条, 相离 4 ,外切 3 , 相交 2, 内切 1, 内含 0.
ac-code:
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int x1, y1, r1, x2, y2, r2;
scanf("%d%d%d%d%d%d", &x1, &y1, &r1, &x2, &y2, &r2);
double d;
d = sqrt( 1.0*((x1-x2)*(x1-x2) + (y2-y1)*(y2-y1)) );//sqrt会损失精度,以后可以把要比较的平方
int a;
if(d==0.0 && r1==r2)	a = -1;
else  if(d > 1.0*(r1+r2))	a = 4;
else  if(d==1.0*(r1+r2))	a = 3;
else  if(d>1.0*(fabs(r1-r2)) && d < 1.0*(r1+r2))	a = 2;
else  if(d==1.0*(fabs(r1-r2)))  a = 1;
else  if(d < 1.0*(fabs(r1-r2))) a = 0;
printf("%d\n", a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: