您的位置:首页 > 其它

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)Problem A Super Mobile Charger

2015-12-28 15:51 555 查看
Problem A Super Mobile Charger

Accept: 217 Submit: 402

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

While HIT ACM Group finished their contest in Shanghai and is heading back Harbin, their train was delayed due to the heavy snow. Their mobile phones are all running out of battery very quick. Luckily, zb has a super mobile charger that can charge all phones.

There are N people on the train, and the i-th phone has p[i] percentage of power, the super mobile charger can charge at most M percentage of power.

Now zb wants to know, at most how many phones can be charged to full power. (100 percent means full power.)



Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, the first line contains two integers N, M(1 <= N <= 100,0 <= M <= 10000) , the second line contains N integers p[i](0 <= p[i] <= 100) meaning the percentage of power of the i-th phone.



Output

For each test case, output the answer of the question.



Sample Input

2

3 10

100 99 90

3 1000

0 0 0



Sample Output

2

3

题意:你有一个超级充电宝,别人的充电宝充到100%就满了,问你可以给几个人充满电。

思路:电量从大到小排序,算最多能给几个人充,ps:对方电满的话也算充了1个。

ac-code:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
bool cmp(int a, int b)
{
return a > b;
}
int p[105];
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int n,m;
scanf("%d%d", &n, &m);
int i,j,k;
for(i = 0; i < n; i++)
scanf("%d", &p[i]);
int sum = 0;
sort(p, p+n,cmp);
for(i = 0 ; i < n; i++)
{
if(p[i]==100)
sum++;
else{
m = m-(100-p[i]);
sum++;
if(m < 0){
sum--;
break;
}
}
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: