您的位置:首页 > 其它

hdoj1501Zipper【dfs】

2015-12-28 15:37 627 查看


Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8489    Accepted Submission(s): 2997


Problem Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

 

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

 

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

 

Source

Pacific Northwest 2004

 

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
bool vis[210][210];
char a[210],b[210],c[410];
int la,lb,lc;
bool dfs(int i,int j,int k){
if(k==lc){
return true;
}
if(vis[i][j])return false;
vis[i][j]=true;
if(i<la){
if(a[i]==c[k]&&dfs(i+1,j,k+1))return true;
}
if(j<lb){
if(b[j]==c[k]&&dfs(i,j+1,k+1))return true;
}
return false;
}
int main()
{
int t,i,j,k=1;
scanf("%d",&t);
while(t--){
scanf("%s %s %s",a,b,c);
memset(vis,false,sizeof(vis));
la=strlen(a);
lb=strlen(b);
lc=strlen(c);
printf("Data set %d: ",k++);
if(dfs(0,0,0))
printf("yes\n");
else
printf("no\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj1501Zipperdfs