您的位置:首页 > 其它

1001. A+B Format (20)

2015-12-27 18:55 309 查看
Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format. 
Sample Input
-1000000 9

Sample Output
-999,991

#include <iostream>
#include <stack>
using namespace std;

void PrintNum(int num)
{
if (num<0)  //处理负数
{
cout<<'-';
num=-num;
}

if (num<1000)
{
cout<<num;  //处理和小于三位数的情况
}else
{
stack<int> Q;
int remain=0,temp=0;
while (num>999) //将结果每三位作为一个数字存入栈
{
remain=num%1000;
Q.push(remain);
num/=1000;
}
cout<<num;
while (!Q.empty())
{
temp=Q.top();
Q.pop();
if (temp>=100)
{
cout<<','<<temp;
}else if(temp>=10)
{
cout<<",0"<<temp;   //该三位数是有效十位数时补一个0
}else
{
cout<<",00"<<temp;  //该三位数是有效个位数时补两个0
}

}
}
}

int main(int argc, const char * argv[])
{
int a=0,b=0,temp=0;
cin>>a>>b;
temp=a+b;
PrintNum(temp);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: