您的位置:首页 > 其它

UVA 11636 (贪心)

2015-12-27 14:47 253 查看
When you rst made the computer to print the sentence \Hello World!", you felt so happy, not

knowing how complex and interesting the world of programming and algorithm will turn out to be.

Then you did not know anything about loops, so to print 7 lines of \Hello World!", you just had to

copy and paste some lines. If you were intelligent enough, you could make a code that prints \Hello

World!" 7 times, using just 3 paste commands. Note that we are not interested about the number

of copy commands required. A simple program that prints \Hello World!" is shown in Figure 1. By

copying the single print statement and pasting it we get a program that prints two \Hello World!"

lines. Then copying these two print statements and pasting them, we get a program that prints four

\Hello World!" lines. Then copying three of these four statements and pasting them we can get a

program that prints seven \Hello World!" lines (Figure 4). So three pastes commands are needed in

total and Of course you are not allowed to delete any line after pasting. Given the number of \Hello

World!" lines you need to print, you will have to nd out the minimum number of pastes required to
make that program from the origin program shown in Figure 1.

Input

The input le can contain up to 2000 lines of inputs. Each line contains an integer N (0 < N < 10001)

that denotes the number of \Hello World!" lines are required to be printed.

Input is terminated by a line containing a negative integer.

Output

For each line of input except the last one, produce one line of output of the form `Case X: Y ' where

X is the serial of output and Y denotes the minimum number of paste commands required to make a

program that prints N lines of \Hello World!".

Sample Input

2

10

-1

Sample Output

Case 1: 1
Case 2: 4

题意:你开始有1条语句,你每次可以复制当前任意句,问最少需要几次可以完成复制

举个例子 ;8

1---->2------>4------>8

题解:每次乘以2倍肯定花费最少次数,然后直接模拟

#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
int n,cas=0;
while(~scanf("%d",&n))
{
if(n<0)break;
int ans=0;
int tt=1;
while(tt<n)
{
tt<<=1;
ans++;
}
printf("Case %d: %d\n",++cas,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: