您的位置:首页 > 其它

Hdu 2095之解题报告

2015-12-27 00:09 309 查看
[align=left]Problem Description[/align]
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and
your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card
number of 3, because 3 is the number that different from all the others.

[align=left]Input[/align]
The input file will consist of several cases.

Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

[align=left]Output[/align]
For each case, output an integer in a line, which is the card number of your present.

[align=left]Sample Input[/align]

5
1 1 3 2 2
3
1 2 1
0


[align=left]Sample Output[/align]
3
2


这是我第一次见到要用到异或位运算符来解决的问题;

A^A=0

A^0=A

真激动;

代码:

#include <stdio.h>

int main(){

int n;
while(scanf("%d",&n)!=EOF,n){
int i,a = 0,b;
for( i = 0 ; i < n ; ++i ){
scanf("%d",&b);
a^=b;
}

printf("%d\n",a);
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: