您的位置:首页 > 产品设计 > UI/UE

hdu acm 3836 Equivalent Sets

2015-12-25 17:42 489 查看
[align=left]Problem Description[/align]
To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.

You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.

Now you want to know the minimum steps needed to get the problem proved.
 

[align=left]Input[/align]
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.

Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
 

[align=left]Output[/align]
For each case, output a single integer: the minimum steps needed.
 

[align=left]Sample Input[/align]

4 0
3 2
1 2
1 3

 

[align=left]Sample Output[/align]

4
2
HintCase 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.

 
解题关键:题意是让求至少添加多少条边才能使其为一个强连通分量,就是缩点后求入度=0和出度=0的最大值。

#include<iostream>
using namespace std;
#include<string.h>
#include<algorithm>
int instack[50005],Belong[50005],stackn[50005];
int top,Low[50005],DFN[50005],head[50005],f,cnt,scnt;
int n,m;
struct node
{
int e,next;
}edge[60000];
void add(int s,int e)
{
edge[f].e=e;
edge[f].next=head[s];
head[s]=f++;
}
void tarjan(int s)
{
int t,k,i;
DFN[s]=Low[s]=++cnt;
stackn[top++]=s;
instack[s]=1;
for(i=head[s];i!=-1;i=edge[i].next)
{
k=edge[i].e;
if(!DFN[k])
{
tarjan(k);
Low[s]=min(Low[k],Low[s]);
}
else if(instack[k])
{
Low[s]=min(Low[s],DFN[k]);
}
}
if(Low[s]==DFN[s])
{
scnt++;
do
{
t=stackn[--top];
Belong[t]=scnt;
instack[t]=0;
}
while(s!=t);
}
}
int main()
{
int i,a[50005],b[50005],k;
while(cin>>n>>m)
{
memset(head,-1,sizeof(head));
f=1;
for(i=0;i<m;i++)
{
cin>>a[i]>>b[i];
add(a[i],b[i]);
}
memset(DFN,0,sizeof(DFN));
top=scnt=cnt=0;
for(i=1;i<=n;i++)
if(!DFN[i])
tarjan(i);
int res1=0,res2=0,ans;
int out[50005],in[50005];
memset(out,0,sizeof(out));
memset(in,0,sizeof(in));
for(i=1;i<=n;i++)
for(k=head[i];k!=-1;k=edge[k].next)
{
int v=edge[k].e;
if(Belong[i]!=Belong[v])
{
out[Belong[i]]++;
in[Belong[v]]++;
}
}
for(i=1;i<=scnt;i++)
{
if(!out[i])res1++;
if(!in[i])res2++;
}
if(scnt<=1)ans=0;
else ans=max(res1,res2);
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: