您的位置:首页 > 其它

hdu 1158(DP)

2015-12-24 17:18 447 查看

Employment Planning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


[align=left]Problem Description[/align]
A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker
is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order
to keep the lowest total cost of the project.

 

[align=left]Input[/align]
The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of
the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.

 

[align=left]Output[/align]
The output contains one line. The minimal total cost of the project.

 

[align=left]Sample Input[/align]

3
4 5 6
10 9 11
0

 

[align=left]Sample Output[/align]

199
解题思路:这道题目的状态其实很明显,dp[i][j]表示第i个月一共找了j个人,那么 dp[i][j] = min{dp[i-1][k] + (j-k)*fire + j*salary} or dp[i][j]=min{dp[i-1][k] + (k - j)*hire + j*salary}。。。
不知道为什么会WA,别人和我一样的思路却能够AC。。。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int inf = 0x7ffffff;
int n,h,f,s;
int work[13],dp[13][110];

int main()
{
while(scanf("%d",&n)!=EOF && n)
{
int maximum = 0;
scanf("%d%d%d",&h,&s,&f);
for(int i = 1; i <= n; i++)
{
scanf("%d",&work[i]);
maximum = max(maximum,work[i]);
}
for(int i = work[1]; i <= maximum; i++)
dp[1][i] = i * (h + s);
for(int i = 2; i <= n; i++)
for(int j = work[i]; j <= maximum; j++)
for(int k = work[i-1]; k <= maximum; k++)
{
if(k > j)
dp[i][j] = min(dp[i][j],dp[i-1][k] + (k - j) * f + j * s);
else
dp[i][j] = min(dp[i][j],dp[i-1][k] + (j - k) * h + j * s);
}
int ans = inf;
for(int i = work
; i <= maximum; i++)
ans = min(ans,dp
[i]);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dp