您的位置:首页 > 其它

hdu 5583 Kingdom of Black and White

2015-12-23 18:39 363 查看


Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 585 Accepted Submission(s): 193



Problem Description

In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now N frogs
are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is
the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of at most one frog and thus the strength of those frogs might change.

The frogs wonder the maximum possible strength after the witch finishes her job.



Input

First line contains an integer T,
which indicates the number of test cases.

Every test case only contains a string with length N,
including only 0 (representing

a black frog) and 1 (representing
a white frog).

⋅ 1≤T≤50.

⋅ for
60% data, 1≤N≤1000.

⋅ for
100% data, 1≤N≤105.

⋅ the
string only contains 0 and 1.



Output

For every test case, you should output "Case #x: y",where x indicates
the case number and counts from 1 and y is
the answer.



Sample Input

2
000011
0101




Sample Output

Case #1: 26
Case #2: 10




Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)



题意:例如000011,有连续为0的子序列长度为4,连续为1的子序列长度为2,所以这段字符串的价值为4*4+2*2=20,女巫最多可以将一个0或1改成1或0,那么把第5个字符1改成0,最后可以得到5*5+1*1=26

/*

本来以为很快就做出来,结果坑了囧。

开始想的是直接求怎样能得出最长的字段,然后求答案

但是发现110001这种会有问题,于是把他们的每段长度离散化处理

对于长为1的,变化后就莫有了- -

对于长度超过了1的,只需要变化它的左右端点位置 110001 => 100001 || 110000(取其他位置只会变得更小)

所以我们根据字段长度以及字段位置进行分类讨论

*/

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
using namespace std;
typedef long long ll;
const int maxn = 101000;
const int INF = 0x3f3f3f3f;

char a[maxn];
ll p[maxn];

int main()
{
    int T;
    int cas = 1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",a);
        int len = strlen(a);
        ll ans = 0;
        int tot = 1;
        int l = 0;
        while(l < len)          //先离散化处理
        {
            int r=l;
            while(r<len && a[r]==a[l])
                r++;
            p[tot]=r-l;
            ans+=p[tot]*p[tot];
            tot++;
            l=r;
        }
        ll pans = ans;
        for(int i = 1; i < tot; i++)
        {
            ll tans = ans;
            ll sum = 0;
            if(p[i] == 1)      //连续长度为1的情况
            {
                tans -=1;
                sum = 1;
                if(i > 1)
                {
                    tans -= p[i-1]*p[i-1];
                    sum += p[i-1];
                }
                if(i < tot-1)
                {
                    tans-=p[i+1]*p[i+1];
                    sum += p[i+1];
                }
                pans = max(pans,tans+=sum*sum);
            }
            else        //如果连续长度超过1,则讨论其左右的情况
            {
                if(i > 1)
                {
                    ll tt = tans;
                    tt -= p[i]*p[i];
                    tt-= p[i-1]*p[i-1];
                    tt += (p[i-1]+1)*(p[i-1]+1);
                    tt += (p[i]-1)*(p[i]-1);
                    pans = max(pans,tt);
                }

                if(i < tot-1)
                {
                    ll tt = tans;
                    tt -= p[i]*p[i];
                    tt-= p[i+1]*p[i+1];
                    tt += (p[i+1]+1)*(p[i+1]+1);
                    tt += (p[i]-1)*(p[i]-1);
                    pans = max(pans,tt);
                }
            }
        }
        printf("Case #%d: %I64d\n",cas++,pans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: