您的位置:首页 > 其它

LA 3027 (并查集)

2015-12-23 00:39 351 查看
A very big corporation is developing its corporative network. In the beginning each of the N enterprises

of the corporation, numerated from 1 to N, organized its own computing and telecommunication center.

Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters,

each of them served by a single computing and telecommunication center as follow. The corporation

chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other

cluster B (not necessarily the center) and link them with telecommunication line. The length of the

line between the enterprises I and J is |I −J|(mod 1000). In such a way the two old clusters are joined

in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the

lengths of the lines linking an enterprise to its serving center could be changed and the end users would

like to know what is the new length. Write a program to keep trace of the changes in the organization

of the network that is able in each moment to answer the questions of the users.

Your program has to be ready to solve more than one test case.

Input

The first line of the input file will contains only the number T of the test cases. Each test will start

with the number N of enterprises (5 ≤ N ≤ 20000). Then some number of lines (no more than 200000)

will follow with one of the commands:

E I — asking the length of the path from the enterprise I to its serving center in the moment;

I I J — informing that the serving center I is linked to the enterprise J.

The test case finishes with a line containing the word ‘O’. The ‘I’ commands are less than N.

Output

The output should contain as many lines as the number of ‘E’ commands in all test cases with a single

number each — the asked sum of length of lines connecting the corresponding enterprise with its serving

center.

Sample Input

1

4

E 3

I 3 1

E 3

I 1 2

E 3

I 2 4

E 3

O

Sample Output

0

2

3
5

题意:简单说求当前的节点与根的距离

题解:用并查集就可以方便的表达这棵树,使用一个数组去保存一下路径长度,然后遍历一下树就可以了,不过时间好长,据说做这一题可以路径压缩,加速查找速度。表示不会。。。

这里注意一下不要使用以下语句遍历树

int find(int x)
{
return x==fa[x]?x:fa[x]=find(fa[x]);
}

他会改变当前的点的关系,而破坏了树路径
还是改为非递归形式查找

while(x!=fa[x])
{
ans+=path[x];
x=fa[x];
}

#include<iostream>
#include<cstdio>
#include<map>
#include<algorithm>
#include<string>
#include<cmath>
#include<vector>
#include<queue>
#include<deque>
#include<cstring>
#include<set>
#include<vector>
using namespace std;
#define LL long long
#define N 300005
#define mod 1000
int fa
;
int path
;
inline void init()
{
for(int i=0;i<N;i++)
{
fa[i]=i;
path[i]=0;
}
}
int ans;
void find(int x)
{
while(x!=fa[x])
{
ans+=path[x];
x=fa[x];
}
}

int main()
{
#ifdef CDZSC
freopen("i.txt","r",stdin);
#endif
char op[10];
int t,n,x,y;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
init();
while(~scanf("%s",op))
{
if(op[0]=='O')break;
else if(op[0]=='I')
{
scanf("%d%d",&x,&y);
fa[x]=y;
path[x]=(abs(x-y))%mod;
}
else
{
ans=0;
scanf("%d",&x);
find(x);
printf("%d\n",ans);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: