您的位置:首页 > 其它

POJ 3617 Best Cow Line(贪心)

2015-12-22 13:41 501 查看
Language:
Default

Best Cow Line

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14945 Accepted: 4244
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD

Source

USACO 2007 November Silver
#include <cstdio>

const int N = 2010;

int main() {
char str
;
int n;
scanf("%d", &n);
for (int i = 0; i < n; ++i)
scanf("%s", str + i);
int l = 0, r = n - 1;
int cnt = 0;

while (l <= r) {
bool flag = false;
for (int i = 0; l + i < r - i; ++i) {
if (str[l + i] < str[r - i]) {
flag = true;
break;
}
else if (str[l + i] > str[r - i]) {
flag = false;
break;
}
}
if (flag) putchar(str[l++]);
else putchar(str[r--]);
if ((++cnt) % 80 == 0) {
puts("");
cnt = 0;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: