您的位置:首页 > 其它

poj1852Ants

2015-12-20 17:58 281 查看
Language:
Default

Ants

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12896 Accepted: 5640
Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time. 

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
int t,n,m,i,j,k,l;
scanf("%d",&t);
while(t--){
scanf("%d%d",&l,&n);
int minn=inf,maxn=0,pos,temp=inf;
for(i=0;i<n;++i){
scanf("%d",&pos);
if(abs(l-2*pos)<temp){
temp=abs(l-2*pos);
minn=pos;
}
maxn=max(maxn,max(pos,abs(l-pos)));
}
printf("%d %d\n",min(minn,l-minn),maxn);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj1852Ants