您的位置:首页 > 其它

hdoj--2138--How many prime numbers(暴力模拟)

2015-12-20 17:56 369 查看

How many prime numbers

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14686 Accepted Submission(s): 5093


[align=left]Problem Description[/align]
Give you a lot of positive integers, just to find out how many prime numbers there are.

[align=left]Input[/align]
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

[align=left]Output[/align]
For each case, print the number of prime numbers you have found out.

[align=left]Sample Input[/align]

3
2 3 4


[align=left]Sample Output[/align]

2


[align=left]Author[/align]
wangye

[align=left]Source[/align]
HDU 2007-11 Programming Contest_WarmUp

#include<cstdio>
#include<cmath>
#include<string.h>
#include<algorithm>
using namespace std;
long long s,ans;
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
ans=0;
int flog=1,i;
for(int j=0;j<n;j++)
{
scanf("%lld",&s);
for(i=2,flog=1;flog&&i<=sqrt(s);i++)
if(s%i==0)
flog=0;
if(flog)
ans++;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: