您的位置:首页 > 其它

POJ-1852(Ants)

2015-12-20 17:34 330 查看
POJ-1852(Ants)

                                                                                                                               
Ants

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12891 Accepted: 5636
Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in
opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two
numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number
is the latest possible such time.

Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output
4 8
38 207

题意:在一个杆子上,长度为m 厘米(题目中每组测试数据的第一个整数),杆子上有n个蚂蚁,n个蚂蚁走的方向为未知,每秒走1cm,在蚂蚁行走的过程中,若两只蚂蚁碰面了,则两只蚂蚁都调头,沿着刚才相反的方向继续爬行,直至所有蚂蚁全部爬出杆子。问这n个蚂蚁最后全部走出杆子所需的最短时间和最长时间。
求最短时间:有三种情况:







求最长时间:



原因:无论a2方向如何,a1与a2终究要相撞,同理a4与a5终究也要相撞。当a1与a2相撞时,可以看做a1把灵魂给了a2,a1与a2全部调头,a1走出杆,a2沿着a1最初的方向走,然后a2与a3碰撞,a2把a1的灵魂给了a3,a3沿着a1最初的方向走,a2从左边走出杆。同上,a4带着a5的灵魂即沿着a5最初的方向走,a5从右边走出杆,当a3与a4碰撞时,相当于灵魂互换,a4带着a1的灵魂,即沿着a1的最初方向往右走,从右边走出杆,a3带着a5的灵魂,即沿着a5的最初方向往左走,从左边走出杆。即最终可以看做a1的灵魂从右边走出去,a5的灵魂从左边走出去。a1与a5的灵魂是最后从杆子上走出去的。即:所需最长时间为sum=max(m1.m2);

My  solution:

/*2015.12.20*/

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[1010000];
int main()
{
int t,n,i,j,k,l,m1,m2,sum,m;
double h;
scanf("%d",&t);
while(t--)
{
m=0;
sum=0;
scanf("%d%d",&l,&n);
h=l/2.0;//杆的中点
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(a[i]<h)//统计中点左边的蚂蚁数目
m++;
}
sort(a,a+n);
if(m==0)//蚂蚁全在杆的中点的右半部分
printf("%d ",l-a[0]);
else
if(m==n)//蚂蚁全在杆的中点的左半部分
printf("%d ",a[n-1]);
else//左右两边都有蚂蚁
{
if((h-a[m-1])>(a[m]-h))
printf("%d ",l-a[m]);
else
printf("%d ",a[m-1]);
}
m1=l-a[0];
m2=a[n-1];
if(m1>m2)//求最长时间
sum=m1;
else
sum=m2;
printf("%d\n",sum);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: