您的位置:首页 > 其它

BZOJ3212 A Simple Problem with Integers

2015-12-19 14:49 218 查看
3212: Pku3468 A Simple Problem with Integers

Time Limit: 1 Sec Memory Limit: 128 MB

Submit: 1277 Solved: 559

[Submit][Status][Discuss]

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.

“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5

1 2 3 4 5 6 7 8 9 10

Q 4 4

Q 1 10

Q 2 4

C 3 6 3

Q 2 4

Sample Output

4

55

9

15

HINT

The sums may exceed the range of 32-bit integers.

一开始没看懂是和可能超过32位。。long long+树状数组水过,不知为何BZOJ还有这种水题。。

附上本蒟蒻的代码:

#include<cstdio>
using namespace std;
int n,m,i,x,y,z,k;
long long a[100001],p;
char c[2];

int lowbit(int x)
{
return x&(-x);
}

void add(int loc,int value)
{
int j;
for (j=loc;j<=n;j+=lowbit(j))
a[j]+=value;
}

long long query(int loc)
{
int j;
long long ans=0;
for (j=loc;j>=1;j-=lowbit(j))
ans+=a[j];
return ans;
}

int main()
{
scanf("%d %d",&n,&m);
for (i=1;i<=n;i++)
{
scanf("%lld",&p);
add(i,p);
}
for (i=1;i<=m;i++)
{
scanf("%s",&c);
if (c[0]=='Q')
{
scanf("%d %d",&x,&y);
printf("%lld\n",query(y)-query(x-1));
}
if (c[0]=='C')
{
scanf("%d %d %d",&x,&y,&z);
for (k=x;k<=y;k++)
add(k,z);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: