您的位置:首页 > 其它

Lowest Bit

2015-12-17 21:34 363 查看

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10231 Accepted Submission(s): 7503



[align=left]Problem Description[/align]
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

[align=left]Input[/align]
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

[align=left]Output[/align]
For each A in the input, output a line containing only its lowest bit.

[align=left]Sample Input[/align]

26
88
0


[align=left]Sample Output[/align]

2
8


[align=left]代码实现:[/align]

#include "iostream"
#include "cmath"
using namespace std;
int main()
{
int n;
while(cin>>n&&n)
{
int i=0;
while(n/2)
{
int m=n%2;
if(m)//找到最先的1,结束循环
break;
n=n/2;
i++;
}
cout<<pow(2,i)<<endl;
}
return 0;
}


别人的代码(不太懂怎么实现的):
#include<stdio.h>
int main()
{	int a;
while(scanf("%d",&a),a)
printf("%d\n",a&(-a));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: