您的位置:首页 > 其它

POJ 3187 Backward Digit Sums(next_permutation()暴力枚举)

2015-12-15 16:45 246 查看
[align=center]Backward Digit Sums[/align]

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 5412
Accepted: 3123
Description
FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They
repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

3   1   2   4

4   3   6

7   9

16

Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic
capabilities. 

Write a program to help FJ play the game and keep up with the cows.
Input
Line 1: Two space-separated integers: N and the final sum.
Output
Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.
Sample Input
4 16

Sample Output
3 1 2 4

Hint
Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题意:有一个n,然后有从1~n这些数,按一定顺序排列,如上题中给出的相加方法,可以得到sum。现在给出n和sum,求最小的排列。

真是忠实函数狗,暴搜DFS从不练,一碰到这种题就直接next_permutation()函数了。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[15],b[15];
int main()
{
int n,sum,i,k;
while(scanf("%d%d",&n,&sum)!=EOF)
{
for(i=0;i<n;++i)
a[i]=i+1;
k=n-1;
do
{
for(i=0;i<n;++i)
b[i]=a[i];
k=n;
while(k--)
{
for(i=0;i<k;++i)
b[i]+=b[i+1];
}
if(b[0]==sum)
break;
}while(next_permutation(a,a+n));
for(i=0;i<n-1;++i)
printf("%d ",a[i]);
printf("%d\n",a[i]);
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: