您的位置:首页 > 其它

HD1712ACboy needs your help(纯裸分组背包)

2015-12-15 11:36 232 查看

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5589 Accepted Submission(s):
3043


[align=left]Problem Description[/align]
ACboy has N courses this term, and he plans to spend at
most M days on study.Of course,the profit he will gain from different course
depending on the days he spend on it.How to arrange the M days for the N courses
to maximize the profit?

[align=left]Input[/align]
The input consists of multiple data sets. A data set
starts with a line containing two positive integers N and M, N is the number of
courses, M is the days ACboy has.
Next follow a matrix A[i][j],
(1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j
days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends
the input.

[align=left]Output[/align]
For each data set, your program should output a line
which contains the number of the max profit ACboy will gain.

[align=left]Sample Input[/align]

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

[align=left]Sample Output[/align]

3
4
6

题意:N个任务M天完成,每个任务花费每天都有一定的收益,问收益最大
分析:分组背包
把N个任务看成N组,其中每组中只能选择一个,也就是每一个任务花费的天数肯定是一个数,然后花费的天数还有费用,分组背包纯裸模板
http://www.cppblog.com/Onway/archive/2010/08/09/122695.html这个讲讲解了第二重和三重循环的设计思路

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAX = 110;
int n,m;
int dp[MAX],a[MAX][MAX];
int main()
{
while(scanf("%d%d", &n, &m) != EOF)
{
if(n == 0 && m == 0)
break;
for(int i = 1; i <= n; i++)
for(int j = 1; j <= m; j++)
scanf("%d", &a[i][j]);
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i++)
{
for(int j = m; j > 0; j--)
{
for(int k = 1; k <=m; k++)
{
if(j >= k)
dp[j] = max(dp[j], dp[j - k] + a[i][k]);
}
}
}
printf("%d\n", dp[m]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: