您的位置:首页 > 编程语言 > PHP开发

A+B for Input-Output Practice (VIII)(没啥用,来凑数)

2015-12-14 22:31 543 查看

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 127789 Accepted Submission(s): 38920



[align=left]Problem Description[/align]
Your task is to calculate the sum of some integers.

[align=left]Input[/align]
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

[align=left]Output[/align]
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

[align=left]Sample Input[/align]

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3


[align=left]Sample Output[/align]

10

15

6


代码实现:
#include<stdio.h>
int main()
{
int T,n,a,sum=0,i;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a);
sum+=a;
}
printf("%d\n",sum);
sum=0;
if(T!=0)
printf("\n");
}
}
我写的():
#include<iostream>
using namespace std;
int main()
{
int T,A[1000];
cin>>T;
while(T--)
{
int sum=0;
cin>>A[0]>>A[1];
int i=1;
while(A[i]!=A[0])
{
i++;
cin>>A[i];
}
for(int j=0;j<i;j++)
sum+=A[j];
if(T)
cout<<sum<<endl<<endl;
else
cout<<sum<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: