您的位置:首页 > 其它

HDU 1060 求N^N的最高位 (数学,科学计数法+log10()函数)

2015-12-14 21:21 246 查看
Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4


Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long ll;
int main()
{
ll n,ans;
long double t;
int _;
cin>>_;
while(_--) {
cin>>n;
t=n*log10(n);
t=t-(ll)t;
ans=pow(10,t);
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: