您的位置:首页 > 其它

HDOJ--1002

2015-12-14 00:24 375 查看


A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 285999 Accepted Submission(s): 55003



Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211


Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


这题用来讲竞赛高精度算法是很不错的,这题是高精度加法计算(若有竞赛需求还需学习高精度减法和乘法),网上的高精度算法资源已经很多了,这里我不再详细解释,

直接上AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{

int t,i,x,num=0;
scanf("%d",&t);
getchar();
char a1[1010],b1[1010];
int a[1010],b[1010],c[1010],lena,lenb,lenc;
while(scanf("%s%s",&a1,&b1)==2)
{
num++;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(c,0,sizeof(c));
lena=strlen(a1);
lenb=strlen(b1);
for(i=0;i<=lena;i++)
a[lena-i]=a1[i]-48;
for(i=0;i<=lenb;i++)
b[lenb-i]=b1[i]-48;
lenc=1,x=0;
while(lenc<=lena || lenc<=lenb)
{
c[lenc]=a[lenc]+b[lenc]+x;
x=c[lenc]/10;
c[lenc]%=10;
lenc++;
}
if(c[lenc]==0)
{
lenc--;
}
printf("Case %d:\n",num);
printf("%s + %s = ",a1,b1);
for(i=lenc;i>=1;i--)
cout<<c[i];
cout<<endl;
if(num!=t)
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: