您的位置:首页 > 其它

HDU 1548 A strange lift

2015-12-13 20:10 351 查看


A strange lift


Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)


Total Submission(s) : 27 Accepted Submission(s) : 20


Font: Times New Roman | Verdana | Georgia


Font Size: ← →


Problem Description

There is a strange lift.The lift can stop can at every floor as you want,

and there is a number Ki(0 <= Ki <= N)

on every floor.The lift have just two buttons: up and down.When you

at floor i,if you press the button "UP" ,

you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same,

if you press the button "DOWN" ,

you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course,

the lift can't go up high than N,and

can't go down lower than 1. For example, there is a buliding with 5 floors,

and k1 = 3, k2 = 3,k3 = 1,k4 = 2,

k5 = 5.Begining from the 1 st floor,you can press the button "UP",

and you'll go up to the 4 th floor,and if

you press the button "DOWN", the lift can't do it, because it can't go

down to the -2 th floor,as you know ,

the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go

to floor B,how many times at least he

has to press the button "UP" or "DOWN"?


Input

The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which

describe above,The second line consist

N integers k1,k2,....kn.

A single 0 indicate the end of the input.


Output

For each case of the input output a interger, the least times you have

to press the button when you on floor A,

and you want to go to floor B.If you can't reach floor B,printf "-1".


Sample Input

5 1 5
3 3 1 2 5
0



Sample Output

3


题解: 题目的意思是  你现在站在第一楼的电梯处,你可以需要从a到b,

然后每个楼层的电梯只有2个按钮,上和下,

而且每层电梯的按钮都有一个值,所代表你不管按了哪个按钮,

都可以去上升或下降到 i-k楼,。问:你最少需要多少次

按电梯可以到达b层。 如果到不了,输出-1;


该题就是一道最短路径的题目,我们可以使用Dijkstra 算法来解,

首先我们用num记录到a到一层楼的最少次数,通过

一次次加入距离a处最少


代码如下:


#include<iostream>
#include<cstring>
#include<stdio.h>
#include<stdlib.h>
#define T 10000000
using namespace std;
int a,b,n;
int biao[210];
int map[210][210];//相邻的两个电梯之间的可通的距离
int num[210];//记录2个电梯之间最少需要多少个点
int Min;
void search()
{
int i,j,k;
memset(biao,0,sizeof(biao));
for(i=1;i<=n;i++)
{
num[i]=map[a][i];
}
num[a]=0;
for(i=1;i<=n;i++)
{
Min=T;
for(j=1;j<=n;j++)
{
if(biao[j]==0&&num[j]<Min)
{
Min=num[j];
k=j;
}
}
if(Min==T) break;
biao[k]=1;
for(j=1;j<=n;j++)
{
if(biao[j]==0&&num[j]>num[k]+map[k][j])
{
num[j]=num[k]+map[k][j];
}
}
}
}

int main()
{
int k,d;
while(cin>>n)
{
if(n==0)  break;
cin>>a>>b;
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
map[i][j]=T;

for(int i=1;i<=n;i++)
{
cin>>d;//每一层电梯去的大小
if(i+d<=n) map[i][i+d]=1;
if(i-d>=1) map[i][i-d]=1;
}
search();
if(num[b]!=T)  cout<<num[b]<<endl;
else cout<<"-1"<<endl;
}
return 0;

}


[/code]

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: