您的位置:首页 > 其它

lightoj--1155-- Power Transmission (最大流拆点)

2015-12-13 19:44 369 查看
Power Transmission

Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu
Submit

Status

Description

DESA is taking a new project to transfer power. Power is generated by the newly established plant in Barisal. The main aim of this project is to transfer Power in Dhaka. As Dhaka is a megacity with almost 10 million people DESA wants to transfer maximum
amount of power through the network. But as always occurs in case of power transmission it is tough to resist loss. So they want to use some regulators whose main aims are to divert power through several outlets without any loss.

Each such regulator has different capacity. It means if a regulator gets 100 units of power and its capacity is 80 units then remaining 20 units of power will be lost. Moreover each unidirectional link (connectors among regulators) has a certain capacity.
A link with capacity 20 units cannot transfer power more than 20 units. Each regulator can distribute the input power among the outgoing links so that no link capacity is over flown. DESA wants to know the maximum amount of power which can be transmitted throughout
the network so that no power loss occurs. That is the job you have to do.



(Do not try to mix the above description with the real power transmission.)

Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

The input will start with a positive integer N (1 ≤ N ≤ 100) indicates the number of regulators. The next line contains
N positive integers indicating the capacity of each regulator from
1 to N. All the given capacities will be positive and not greater than
1000. The next line contains another positive integer M which is the number of links available among the regulators. Each of the following
M lines contains three positive integers i j C.
'i' and 'j' are the regulator index (1 ≤ i, j ≤ N, i ≠ j, 1 ≤ C ≤ 1000) and
C is the capacity of the link. Power can be transferred from
ith
regulator to jth regulator. From a regulator
i to another regulator j, there can be at most one link.

The next line contains two positive integers B and D (1 ≤ B, D and B + D ≤ N).
B is the number of regulators which are the entry point of the network. Power generated in Barisal must enter in the network through these entry points. Similarly
D is the number of regulators connected to Dhaka. These links are special and have infinite capacity. Next line will contain
B+D integers each of which is an index of regulator. The first
B
integers are the index of regulators connected with Barisal. Regulators connected with Barisal are not connected with Dhaka.

Output

For each case of input, print the case number and the maximum amount of power which can be transferred from Barisal to Dhaka.

Sample Input

2

4

10 20 30 40

6

1 2 5

1 3 10

1 4 13

2 3 5

2 4 7

3 4 20

3 1

1 2 3 4

2

50 100

1

1 2 100

1 1

1 2

Sample Output

Case 1: 37

Case 2: 50

Source

Problem Setter: Md. Kamruzzaman
Special Thanks: Jane Alam Jan (Solution, Dataset)

#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define MAXM 300
#define MAXN 50000
#define INF 0x3f3f3f
int dis[MAXM],vis[MAXM],cur[MAXM],head[MAXM];
int n,top,need[MAXM];
struct node
{
int u,v,cap,flow,next;
}edge[MAXN];
void init()
{
top=0;
memset(head,-1,sizeof(head));
}
void add(int a,int b,int c)
{
node E1={a,b,c,0,head[a]};
edge[top]=E1;
head[a]=top++;
node E2={b,a,0,0,head[b]};
edge[top]=E2;
head[b]=top++;
}
void getmap()
{
scanf("%d",&n);
memset(need,0,sizeof(need));
for(int i=1;i<=n;i++)
{
scanf("%d",&need[i]);
add(i,i+n,need[i]);
}
int m;
scanf("%d",&m);
while(m--)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a+n,b,c);
}
int b,d;
scanf("%d%d",&b,&d);
while(b--)
{
int c;
scanf("%d",&c);
add(0,c,need[c]);
}
while(d--)
{
int c;
scanf("%d",&c);
add(c+n,2*n+1,need[c]);
}
}
bool bfs(int s,int t)
{
queue<int>q;
memset(vis,0,sizeof(vis));
memset(dis,-1,sizeof(dis));
q.push(s);
vis[s]=1;
dis[s]=0;
while(!q.empty())
{
int u=q.front();
q.pop();
for(int i=head[u];i!=-1;i=edge[i].next)
{
node E=edge[i];
if(E.cap>E.flow&&!vis[E.v])
{
vis[E.v]=1;
dis[E.v]=dis[E.u]+1;
if(E.v==t) return true;
q.push(E.v);
}
}
}
return false;
}
int dfs(int x,int a,int e)
{
if(x==e||a==0)
return a;
int flow=0,f;
for(int i=cur[x];i!=-1;i=edge[i].next)
{
node &E=edge[i];
if(dis[E.v]==dis[E.u]+1&&(f=dfs(E.v,min(a,E.cap-E.flow),e))>0)
{
E.flow+=f;
edge[i^1].flow-=f;
a-=f;
flow+=f;
if(a==0) break;
}
}
return flow;
}
int MAXflow(int s,int t)
{
int flow=0;
while(bfs(s,t))
{
memcpy(cur,head,sizeof(head));
flow+=dfs(s,INF,t);
}
return flow;
}
int main()
{
int t;
int k=1;
scanf("%d",&t);
while(t--)
{
init();
getmap();
printf("Case %d: %d\n",k++,MAXflow(0,2*n+1));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: