您的位置:首页 > 其它

杭电 3665 Seaside(最短路)(弗洛伊德过)

2015-12-13 19:18 447 查看
无脑模板题~


Seaside

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1452 Accepted Submission(s): 1055



Problem Description

XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town
from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.



Input

There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there
are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the
i-th town and the SMi town is LMi.



Output

Each case takes one line, print the shortest length that XiaoY reach seaside.



Sample Input

5
1 0
1 1
2 0
2 3
3 1
1 1
4 100
0 1
0 1




Sample Output

2




#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int panduan[121];
long long int dis[121][121];
int n;
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                dis[i][j]=0x1f1f1f1f;
            }
        }
        memset(panduan,0,sizeof(panduan));
        for(int i=0;i<n;i++)
        {
            int a,b,c,d;
            scanf("%d%d",&a,&b);
            panduan[i]=b;
            for(int j=0;j<a;j++)
            {
                scanf("%d%d",&c,&d);
                dis[i][c]=dis[c][i]=d;
            }
        }
        int i,j,k;
            for(k=0;k<n;k++)
                for(i=0;i<n;i++)
                    for(j=0;j<n;j++)
                        if(dis[i][j]>dis[i][k]+dis[k][j])
                           dis[i][j]=dis[i][k]+dis[k][j];
        int output=0x1f1f1f1f;
        for(int i=0;i<n;i++)
        {
            if(panduan[i])
            {
                if(dis[0][i]<output)output=dis[0][i];
            }
        }
        printf("%d\n",output);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: