您的位置:首页 > 其它

hdu1008(基础)

2015-12-12 23:23 393 查看

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 57659    Accepted Submission(s): 31571


[align=left]Problem Description[/align]
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one
floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

 

[align=left]Input[/align]
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

 

[align=left]Output[/align]
Print the total time on a single line for each test case.

 

[align=left]Sample Input[/align]

1 2
3 2 3 1
0

 

[align=left]Sample Output[/align]

17
41

 题目大意:某幢大楼只有一个电梯,输入一列数,表示在第几层停一次,已知每向上一层需要6秒,向下一层需要4秒,停一次需要5秒。
问最终耗费多少时间?
其他没啥,需要注意一点当一个层数连续出现几次,没出现一次就表示停5秒。
AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
int n;
int a[1010];
while(scanf("%d",&n)&&n)
{
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
if(n==1&&a[0]==0)
{
printf("0\n");
continue;
}
else
{
int sum=a[0]*6+5;
for(int i=1;i<n;i++)
{
if(a[i-1]<a[i])
{
sum+=(a[i]-a[i-1])*6+5;
}
else if(a[i-1]>a[i])
{
sum+=(a[i-1]-a[i])*4+5;
}
else if(a[i-1]==a[i]) sum+=5;
}
printf("%d\n",sum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: