您的位置:首页 > 其它

hdu 1312 Red and Black

2015-12-10 14:18 429 查看
[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

[align=left]Sample Output[/align]

45
59
6
13

[align=left]Source[/align]
Asia 2004, Ehime (Japan), Japan Domestic

题解: 求 “.”数, 注意 行和列 吧... 找了好久才找到错在哪里...

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <limits.h>
#include <algorithm>
#include <iostream>
#include <ctype.h>
#include <iomanip>
#include <queue>
#include <map>
#include <stdlib.h>
using namespace std;

int ans,m,n;
char v[30][30];
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};

void dfs(int x,int y)
{
ans++;
v[x][y]='#';
for(int k=0;k<4;k++){
int px=x+dx[k];
int py=y+dy[k];
if(v[px][py]=='.' && py<m && px<n && px>=0 && py>=0){
dfs(px,py);
}
}
}

int main()
{
while(~scanf("%d%d",&m,&n)&&m!=0&&n!=0){
int e,d,i,j;
for(i=0;i<n;i++)
scanf("%s",v[i]);
for(i=0;i<n;i++){
for(j=0;j<m;j++){
if(v[i][j]=='@'){
e=i;
d=j;
}
}
}
ans=0;
dfs(e,d);
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: