您的位置:首页 > 其它

poj-1094-Sorting It All Out

2015-12-09 17:48 295 查看
传送门

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.

Sorted sequence cannot be determined.

Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input

4 6

A<B

A<C

B<C

C<D

B<D

A<B

3 2

A<B

B<A

26 1

A<Z

0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.

Inconsistency found after 2 relations.

Sorted sequence cannot be determined.

拓扑排序问题

该题题意明确,就是给定一组字母的大小关系判断他们是否能组成唯一的拓扑序列。是典型的拓扑排序,但输出格式上确有三种形式:

1. 该字母序列有序,并依次输出;

2. 该序列不能判断是否有序;

3. 该序列字母次序之间有矛盾,即有环存在。

而这三种形式的判断是有顺序的:先判断是否有环(3),再判断是否有序(1),最后才能判断是否能得出结果(2)。注意:对于(2)必须遍历完整个图,而(1)和(3)一旦得出结果,对后面的输入就不用做处理了。

代码:

[code]#include <iostream>
#include <cmath>
#include <cstdio>
#include <iomanip>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
const int N = 30;
using namespace std;
int map

, in
, n, m, q[27];
char alp
;
int toposort()
{
    int tmp
, i, t, a, p = 0, res = 1;
    stack<int> q;
    a = 0;
    for (i = 0; i < n; i++)
    {
        tmp[i] = in[i];
        if (!tmp[i])
        {
            q.push(i);
            a++;
        }
    }
    while(!q.empty())
    {
        if (q.size() > 1)   res = -1;
        t = q.top();
        alp[p++] = t+'A';
        q.pop();
        for (i = 0; i < n; i++)
        {
            if (map[t][i])
            {
                tmp[i]--;
                if (!tmp[i])
                {
                    q.push(i);
                }
            }
        }
    }
    alp[p] = 0;
    if (p != n) return 0;
    return res;
}
int main()
{
#ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
#endif  
    int i, j, ans, sign; 
    string str;
    while(cin >> n >> m && n)
    {
        memset(map, 0, sizeof(map));
        memset(in, 0, sizeof(in));
        sign = 0;
        for (i = 1; i <= m; i++)
        {
            cin >> str;
            if(sign)    continue;
            map[str[0]-'A'][str[2]-'A'] = 1;
            in[str[2]-'A']++;
            ans = toposort();
            if (ans == 0)
            {
                cout << "Inconsistency found after " << i << " relations." << endl;
                sign = 1;
            }
            else if (ans == 1)
            {
                cout << "Sorted sequence determined after " 
                        << i << " relations: " << alp << ".\n";
                sign = 1;
            }
        }
        if (!sign)
        {
            cout << "Sorted sequence cannot be determined.\n";
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: