您的位置:首页 > 其它

hdu 2639 Bone Collector II(01背包 第K大价值)

2015-12-09 15:53 417 查看

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3355 Accepted Submission(s):
1726


[align=left]Problem Description[/align]
The title of this problem is familiar,isn't it?yeah,if
you had took part in the "Rookie Cup" competition,you must have seem this
title.If you haven't seen it before,it doesn't matter,I will give you a
link:

Here is the link:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today
we are not desiring the maximum value of bones,but the K-th maximum value of the
bones.NOTICE that,we considerate two ways that get the same value of bones are
the same.That means,it will be a strictly decreasing sequence from the 1st
maximum , 2nd maximum .. to the K-th maximum.

If the total number of
different values is less than K,just ouput 0.

[align=left]Input[/align]
The first line contain a integer T , the number of
cases.
Followed by T cases , each case three lines , the first line contain
two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the
number of bones and the volume of his bag and the K we need. And the second line
contain N integers representing the value of each bone. The third line contain N
integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the K-th maximum of
the total value (this number will be less than 231).

[align=left]Sample Input[/align]

3

5 10 2

1 2 3 4 5

5 4 3 2 1

5 10 12
1 2 3 4 5
5 4 3 2 1

5 10 16
1 2 3 4 5
5 4 3 2 1

[align=left]Sample Output[/align]

12
2
0

[align=left]Author[/align]
teddy

[align=left]Source[/align]
百万秦关终属楚

[align=left]Recommend[/align]
teddy | We have carefully selected several similar
problems for you: 2159 1114 3033 1561 1712

还是01背包问题,不过我是第一次写这种类型的题,参考了别人的代码和思想,差不多是一道模板第k大价值题,值得一做。
更新的时候有两个数组A、B,A记录选择第i个物品的从大到小排列,B记录不选择的从大到小排列,然后合并AB,选出AB里面前k个最大的。合并到dp中。。。

题意:第一行三个数,第一个数为物体数量,第二个数总体积,第三个数第k优解。注意!接下来第二行是物体的价值,第三行是物体的体积。
求第k大优解的值是多少。

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int T,i,j,n,m,v,k,kk;
int dp[1005][35],val[1005],vol[1005],A[35],B[35];
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&v,&k);
for(i=0; i<n; i++)
scanf("%d",&val[i]);   //价值
for(i=0; i<n; i++)
scanf("%d",&vol[i]);    //体积
memset(dp,0,sizeof(dp));
int a,b,c;
for(i=0; i<n; i++)
for(j=v; j>=vol[i]; j--)
{
for(kk=1; kk<=k; kk++)  //从最优的向后循环
{
A[kk]=dp[j-vol[i]][kk]+val[i];  //选中i物体
B[kk]=dp[j][kk];         //不选i物体
}
A[kk]=-1;   //-1标记为结尾
B[kk]=-1;
a=b=c=1;
while(c<=k&&(A[a]!=-1||B[b]!=-1))
{
if(A[a]>B[b])   //大的数排在前面
dp[j][c]=A[a++];
else
dp[j][c]=B[b++];
if(dp[j][c]!=dp[j][c-1]) //如果两数相同,则只记录一次
c++;
}
}
printf("%d\n",dp[v][k]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: